Naming of Emails In Document Library

Developer
May 2, 2012 at 2:49 PM

Hi David

I am testing the solution against SP2010 and Outlook 2010 and it all seems to work ok apart from the naming  of the documents in the SharePoint E2Mail Lib. The emails and attachments are saved with a GUID.

Do you have any thoughts on this and what I need to look at in terms if fixing it?

Thanks

Paul

Coordinator
May 2, 2012 at 3:07 PM
The emails and attachments are saved with a GUID to avoid clashes. Meta data on the library should show the email subject and to and From etc.

On 2 May 2012 15:49, paulabedford <notifications@codeplex.com> wrote:

From: paulabedford

Hi David

I am testing the solution against SP2010 and Outlook 2010 and it all seems to work ok apart from the naming of the documents in the SharePoint E2Mail Lib. The emails and attachments are saved with a GUID.

Do you have any thoughts on this and what I need to look at in terms if fixing it?

Thanks

Paul

Read the full discussion online.

To add a post to this discussion, reply to this email (mail2sharepoint@discussions.codeplex.com)

To start a new discussion for this project, email mail2sharepoint@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Developer
May 3, 2012 at 7:52 PM

Got it. I wonder if you can help tho' I have two views - one that displays just emails and one that displays just attachments. I am trying to get the attachments view in one web part to filter based on selection of an email in another web part. I tried using Name and MS2_ParentGUID which seemed to be the logical selections but it does not work. 

Any ideas?

Thanks

Paul

Coordinator
May 4, 2012 at 6:52 AM
I presume you're not wanting to use the email viewer web part in the WSP?

If not then the data in the m2s_parentemailguid is the field that references the email the attachment came from - perhaps try a query string filter rather than a web part connection?



On 3 May 2012, at 20:52, "paulabedford" <notifications@codeplex.com> wrote:

From: paulabedford

Got it. I wonder if you can help tho' I have two views - one that displays just emails and one that displays just attachments. I am trying to get the attachments view in one web part to filter based on selection of an email in another web part. I tried using Name and MS2_ParentGUID which seemed to be the logical selections but it does not work.

Any ideas?

Thanks

Paul