(no available libraries) issue

Sep 2, 2010 at 12:13 PM

Hi.  Just installed this tool.  Looks like a really nice solution.

When I right-click on an email in Outlook 2007 it brings up the dialog box to choose Sharepoint sites properly.  It allows me to navigate to subsites properly.  Unfortunately at every level I get "(no available libraries)". 

Ideas?

Coordinator
Sep 2, 2010 at 12:19 PM

After you've deployed the WSP to your SharePoint server, and activated the features at the site and site collection level (they are named beginning with 'M2S_') - then you should have a new document library template available, called 'M2S Email Library' I think.

Only libraries created with that template will show up in the treeview picker in Outlook - since it has all the content types it needs attached.

Let me know if that helps.

Cheers, David.

Sep 2, 2010 at 12:26 PM

Ah, I see I misunderstood the deployment technique.  I took the instructions to mean that the client provided the "saving" functionality and the .WSP provided additional  functionality.

So, the obvious question is:  what is the chance of getting the client tool to support standard libraries?  The functionality is somewhat limited if it can only save messages into this specific library.

 

Coordinator
Sep 2, 2010 at 12:33 PM

Sorry - I keep meaning to write some *proper* documentation, but time time time!

The reason a custom library is used is because it already has the content types attached, which specify the custom meta data fields that it needs to save the email information (such as TO, CC, Sender etc) into. You can create as many of these libraries in each site that you want. Alternatively, you can manually apply the content types made avaliable in the WSP solution (M2S_Email and M2S_Attachment) to any document library, and it will then show up in the picker. I just thought that keeping all uploaded emails separate from collaboration documents made things tidier.

David.